<!DOCTYPE html>
<html dir="ltr" lang="en">
    <head>
	<script>
	  WebFontConfig = {
		  google: { families: ['Share Tech Mono', 'Lato:400,700'] }
	  };

	  (function() {
	    var wf = document.createElement('script');
	    wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
		      '://ajax.googleapis.com/ajax/libs/webfont/1.4.7/webfont.js';
	    wf.type = 'text/javascript';
	    wf.async = 'true';
	    var s = document.getElementsByTagName('script')[0];
	    s.parentNode.insertBefore(wf, s);
	  })();
	</script>
	<script>document.cookie='resolution='+Math.max(screen.width,screen.height)+'; path=/';</script>
    <link rel="stylesheet" href="https://www.thelinuxrain.com/css/style.min.css?v=10">
  <meta name="google-site-verification" content="mPIuLMMAukIaLD0bpwui4JfmjlaAm_pPqvWhcuXCd48" />
  <title>Sending an Email Using Python | The Linux Rain</title>
  <meta charset="UTF-8">

    <meta name="description" content="Ever wanted to send emails using just Python? A few lines of code and you don&rsquo;t even need to log into your Gmail account to email anyone in the world. In fact, you can do this in your terminal" />
  
  	<meta name="keywords" content="linux, gaming, steam, reviews, news, tutorials" />
   
  <meta name="robots" content="index, follow">
  <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

  <link rel="shortcut icon" href="https://www.thelinuxrain.com/assets/images/favicon.gif" type="image/gif" />
  <link rel="icon" href="https://www.thelinuxrain.com/assets/images/favicon.gif" type="image/gif" />
  <link rel="shortlink" type="text/html" href="https://www.thelinuxrain.com/x/n31g65">


  <!--[if lt IE 9]>
	<script src="https://www.thelinuxrain.com/assets/dist/html5shiv.js"></script>  <![endif]-->

  <meta property="og:site_name" content="The Linux Rain" />
  <meta property="og:type" content="article" />
  <meta property="og:title" content="Sending an Email Using Python | The Linux Rain" />
  <meta property="og:description" content="Ever wanted to send emails using just Python? A few lines of code and you don&rsquo;t even need to log into your Gmail account to email anyone in the world. In fact, you can do this in your terminal" />
  <meta property="og:url" content="https://www.thelinuxrain.com/articles/sending-email-using-python" />
  <meta property="og:image" content="https://www.thelinuxrain.com/content/01-articles/212-sending-email-using-python/headimage.jpg" />

    <meta property="article:section" content="Tutorials" />
  
      <meta property="article:tag" content="email" />
    <meta property="article:tag" content="python" />
    <meta property="article:tag" content="gmail" />
    <meta property="article:tag" content="scripting" />
    <meta property="article:tag" content="commandline" />
    <meta property="article:tag" content="tutorials" />
    
    <meta property="article:published_time" content="2020-10-15T15:00:00+00:00" />
  
</head>

<body id="page" class=" article">

<header id="main-header">
	<a href="https://www.thelinuxrain.com"><h1 class="text-center">
	The Linux Rain	<small class="clearfix">Linux General/Gaming News, Reviews and Tutorials</small>
	</h1>
	</a>
</header>
 <nav id="navbar-main" class="navbar navbar-inverse" role="navigation">
	<div class="container-fluid">
		 <div class="navbar-header">
		      <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1">
			<span class="sr-only">Toggle navigation</span>
			<span class="icon-bar"></span>
			<span class="icon-bar"></span>
			<span class="icon-bar"></span>
		      </button>
		</div>
			<div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
			<ul class="nav navbar-nav">        <li><a class="is-active" href="https://www.thelinuxrain.com">Home</a></li>
        <li><a href="https://www.thelinuxrain.com/about">About</a></li>
        <li><a href="https://www.thelinuxrain.com/contact">Contact</a></li>
        <li><a href="https://www.thelinuxrain.com/submit-an-article">Submit Tip/Article</a></li>
    <li class="dropdown-eligible"><a href="#categories">Categories</a><ul class="sub-menu">
		
			<li><a href="https://www.thelinuxrain.com/category:Reviews">Reviews</a></li>
			<li><a href="https://www.thelinuxrain.com/category:News">News</a></li>
			<li><a href="https://www.thelinuxrain.com/category:Tutorials">Tutorials</a></li>
			<li><a href="https://www.thelinuxrain.com/category:Editorials">Editorials</a></li>
			<li><a href="https://www.thelinuxrain.com/category:Announcements">Announcements</a></li>
			<li><a href="https://www.thelinuxrain.com/category:Previews">Previews</a></li>
			<li><a href="https://www.thelinuxrain.com/category:Upcoming">Upcoming</a></li>
			<li><a href="https://www.thelinuxrain.com/category:Advocacy">Advocacy</a></li>
			<li><a href="https://www.thelinuxrain.com/category:Overviews">Overviews</a></li>
	</ul>
</li></ul>
		</div> <!-- /.navbar-collapse -->
	</div> <!-- /.container-fluid -->
</nav>
<div class="container-fluid">
<div class="main">
<div class="article-content">
				<header>
					<img class="img-responsive center-block" src="https://www.thelinuxrain.com/content/01-articles/212-sending-email-using-python/headimage.jpg">
					<h1 class="text-center">Sending an Email Using Python</h1>
					<h4 class="text-center">By <span class="text-uppercase">Kalyani Rajalingham</span>, published 15/10/2020 in <a href="https://www.thelinuxrain.com/category:Tutorials">Tutorials</a></h4>
				</header>
					<hr>
				<div class="article-inner-content">
					<p><strong>Ever wanted to send emails using just Python? A few lines of code and you don’t even need to log into your Gmail account to email anyone in the world. In fact, you can do this in your terminal.</strong></p>
<p>First, open up your terminal and create a file. I will call mine “emailer.py”.</p>
<pre><code>nano emailer.py</code></pre>
<p>Now, let’s add some code to the file we just created. In the first instance, we will need to import smtplib.</p>
<pre><code>Import smtplib</code></pre>
<p>Next, let’s define the server and the port of the email service we use. In my case, since I use Gmail, the server and port will be that of Gmail’s. However, if you use a service other than Gmail, you can simply Google the server address.  </p>
<pre><code>server = “smtp.gmail.com”
port = 587
smtp = smtplib.SMTP(server, port)</code></pre>
<p>Let’s initiate a secure connection.</p>
<pre><code>smtp.ehlo()
smtp.starttls()</code></pre>
<p>We now need a valid Gmail account (both username and password) to log into. In my case, I created a dummy account just for this. Please note that your Gmail account’s setting must be such that the “less secure apps” (manage your Gmail account &gt;&gt; Security &gt;&gt; Less secure apps access) are on. </p>
<pre><code>user= “videosys262@gmail.com”
password= “Password1.”
smtp.login(user, password)</code></pre>
<p>To define the content that I will be sending:</p>
<pre><code>content = “This email was sent using Python code only”</code></pre>
<p>And finally, to send the message, we use sendmail(from, to, message).</p>
<pre><code>smtp.sendmail(user, user, content)</code></pre>
<p>The entire code would look something like this:</p>
<pre><code>Import smtplib

server = “smtp.gmail.com”
port = 587
smtp = smtplib.SMTP(server, port)

smtp.ehlo()
smtp.starttls()

user= “videosys262@gmail.com”
password= “Password1.”
smtp.login(user, password)

content = “This email was sent using Python code only”

smtp.sendmail(user, user, content)</code></pre>
<p>Once you’ve written the code, the next step is to run it:</p>
<pre><code>python emailer.py</code></pre>
<p>Easy, breezy, beautiful code to send an email.</p>					<hr>
<div class="share-links">
	<h4>Share This</h4>
	<a class="googleplus" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.thelinuxrain.com%2Farticles%2Fsending-email-using-python">Google+</a>
	<a class="twitter" href="https://twitter.com/share?url=https%3A%2F%2Fwww.thelinuxrain.com%2Farticles%2Fsending-email-using-python&text=Sending+an+Email+Using+Python" class="button">Twitter</a>
	<a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.thelinuxrain.com%2Farticles%2Fsending-email-using-python">Facebook</a>
</div>
					<div class="about-author"><hr />
<h4>About the author</h4>
<p>Kalyani Rajalingham (from Sri Lanka, lives in Canada), and is a Linux and code lover.</p></div>										<span class="tags">Tags:
											<a href="/tag:email">email</a>
											<a href="/tag:python">python</a>
											<a href="/tag:gmail">gmail</a>
											<a href="/tag:scripting">scripting</a>
											<a href="/tag:commandline">commandline</a>
											<a href="/tag:tutorials">tutorials</a>
									</span>
				</div> <!-- /.article-inner-content -->
			<div id="disqus_container">
								<div id="disqus_thread"></div>
<script type="text/javascript">
  var disqus_shortname  = 'thelinuxrain'; // required: replace example with your forum shortname
  var disqus_title      = 'Sending an Email Using Python';
  var disqus_developer  = 'false'; // developer mode
  var disqus_identifier = 'articles/sending-email-using-python';
  var disqus_url        = 'https://www.thelinuxrain.com/articles/sending-email-using-python';

  (function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
    dsq.src = 'https://' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
  })();
</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<a href="http://disqus.com" class="dsq-brlink">blog comments powered by <span class="logo-disqus">Disqus</span></a>
			</div>
			</article>
</div> <!-- /.article-content -->
<aside class="right-sidebar">
	<section>
	<form action="https://www.thelinuxrain.com/search">
			<div class="input-group">
				<input class="form-control search-field" type="text" name="q" placeholder="Search..." />
				<span class="input-group-btn">
					<input class="btn search-submit" type="submit" value="" />
				</span>
			</div>
		</form>
	</section>

	<section>
		<h4>Follow Us</h4>
		<div class="social-follow-buttons">
		<a href="https://facebook.com/thelinuxrain" target="_blank"><span class="social-button btn-facebook"></span></a>
		<a href="https://twitter.com/intent/user?screen_name=TheLinuxRain" target="_blank"><span class="social-button btn-twitter"></span></a>
		<a href="feed" target="_blank"><span class="social-button btn-rss"></span></a>
		</div>

	</section>

	<section>
		<h4>Recent Articles</h4>
		<div class="widget_recent_entries">
			<ul class="sidebar-links">

			<li>
				<a href="https://www.thelinuxrain.com/articles/sending-email-using-python">Sending an Email Using Python</a>
			</li>


			<li>
				<a href="https://www.thelinuxrain.com/articles/how-to-set-systemd-to-hibernate-instead-of-suspend-on-laptop-lid-close">How to Set systemd to Hibernate Instead of Suspend on Laptop Lid Close</a>
			</li>


			<li>
				<a href="https://www.thelinuxrain.com/articles/ssh-tunneling">SSH Tunneling</a>
			</li>


			<li>
				<a href="https://www.thelinuxrain.com/articles/rainbow-tables">Rainbow Tables</a>
			</li>


			<li>
				<a href="https://www.thelinuxrain.com/articles/bruteforcing-emails-using-a-simple-python-script">Bruteforcing Emails Using a Simple Python Script</a>
			</li>


			<li>
				<a href="https://www.thelinuxrain.com/articles/how-to-bruteforce-a-hash-from-windows-hash-file-in-python">How to Bruteforce a Hash from Windows Hash File in Python</a>
			</li>


			<li>
				<a href="https://www.thelinuxrain.com/articles/the-complicated-firewall">The Complicated Firewall</a>
			</li>


			<li>
				<a href="https://www.thelinuxrain.com/articles/sneaking-around-in-metal-gear-solid-v-tpp-with-steam-proton">Sneaking around in Metal Gear Solid V: The Phantom Pain, thanks to Steam Proton</a>
			</li>


			<li>
				<a href="https://www.thelinuxrain.com/articles/paper-dungeons-crawler-released-early-access-first-impressions">Paper Dungeons Crawler Released in Early Access; First Impressions</a>
			</li>


			<li>
				<a href="https://www.thelinuxrain.com/articles/liferea-hack-add-links-to-abc-australia-news-items">Liferea hack: add links to ABC (Australia) news items</a>
			</li>

</ul>
			</div>
	</section>
	<section>
		<h4>Editor Picks</h4>
		<div class="widget_recent_entries">
			
<ul class="sidebar-links">

	<li> <a href="https://www.thelinuxrain.com/articles/sending-email-using-python">Sending an Email Using Python</a></li>
	<li> <a href="https://www.thelinuxrain.com/articles/mount-dvd-to-fix-playback-issues">Quick Tip: Mount DVD to Fix Playback Issues</a></li>

</ul>
		</div>
	</section>
	<section>
		<h4>Linux Links</h4>
		<div class="widget_recent_entries">
			
<ul class="sidebar-links">

	<li> <a href="https://www.polydesmida.info/BASHing/">Bob Mesibov's BASHing Blog</a></li>
	<li> <a href="https://www.sudosatirical.com/">Sudo Satirical</a></li>
	<li> <a href="http://www.tuxarena.com/">TuxArena</a></li>

</ul>
		</div>
	</section>
	<section>
	<a href="https://www.resetthenet.org" target="_blank"><img class="img-responsive" src="https://www.thelinuxrain.com/assets/images/take-back-reset-the-net.png"></a>
	</section>
	<section>
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- SidebarAd -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5941131116498030"
     data-ad-slot="4271339906"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
	</section>
	<section>
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- SkyscraperAd -->
<ins class="adsbygoogle"
style="display:block;width:160px;height:600px;margin:0 auto;"
data-ad-client="ca-pub-5941131116498030"
data-ad-slot="7588929504"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
	</section>
</aside>
</div> <!-- /.main -->
</div> <!-- /.container-fluid -->
<div id="bottom-ad">
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<!-- BottomAdResponsive -->
	<ins class="adsbygoogle"
		 style="display:block"
		 data-ad-client="ca-pub-5941131116498030"
		 data-ad-slot="3688184305"
		 data-ad-format="auto"></ins>
	<script>
	(adsbygoogle = window.adsbygoogle || []).push({});
	</script>
</div>
  <footer>
    	<div class="text-center"><p>© 2013-2017 The Linux Rain<br />
Powered by the <a href="http://getkirby.com">KirbyCMS</a><br />
Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.</p></div>
  </footer>
  <script src="https://www.thelinuxrain.com/js/jquery.min.js"></script>  <script src="https://www.thelinuxrain.com/js/bootstrap.min.js"></script>	<script>

	jQuery(document).ready(function($) {

		$('.dropdown-eligible').children('a').append(' <span class="caret"></span>');
		$('.dropdown-eligible').children('a').addClass('dropdown');
		$('.dropdown-eligible').children('a').attr('data-toggle', 'dropdown');
		$('.nav .sub-menu').addClass('dropdown-menu');
	});

	</script>
</body>
</html>
