<!DOCTYPE html>
<html dir="ltr" lang="en">
    <head>
	<script>
	  WebFontConfig = {
		  google: { families: ['Share Tech Mono', 'Lato:400,700'] }
	  };

	  (function() {
	    var wf = document.createElement('script');
	    wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
		      '://ajax.googleapis.com/ajax/libs/webfont/1.4.7/webfont.js';
	    wf.type = 'text/javascript';
	    wf.async = 'true';
	    var s = document.getElementsByTagName('script')[0];
	    s.parentNode.insertBefore(wf, s);
	  })();
	</script>
	<script>document.cookie='resolution='+Math.max(screen.width,screen.height)+'; path=/';</script>
    <link rel="stylesheet" href="http://www.thelinuxrain.com/css/style.min.css?v=10">
  <meta name="google-site-verification" content="mPIuLMMAukIaLD0bpwui4JfmjlaAm_pPqvWhcuXCd48" />
  <title>When will this script finish doing its job? | The Linux Rain</title>
  <meta charset="UTF-8">

    <meta name="description" content="Several of my data-auditing scripts take a long time to execute. Until recently I had no way of knowing how long they'd take. I'd enter the command for the script, press Enter and wait. And wait. I've now discovered the pipeline viewer or pv command, which tracks the progress of my scripts." />
  
  	<meta name="keywords" content="linux, gaming, steam, reviews, news, tutorials" />
   
  <meta name="robots" content="index, follow">
  <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

  <link rel="shortcut icon" href="http://www.thelinuxrain.com/assets/images/favicon.gif" type="image/gif" />
  <link rel="icon" href="http://www.thelinuxrain.com/assets/images/favicon.gif" type="image/gif" />
  <link rel="shortlink" type="text/html" href="http://www.thelinuxrain.com/x/q392rz">


  <!--[if lt IE 9]>
	<script src="http://www.thelinuxrain.com/assets/dist/html5shiv.js"></script>  <![endif]-->

  <meta property="og:site_name" content="The Linux Rain" />
  <meta property="og:type" content="article" />
  <meta property="og:title" content="When will this script finish doing its job? | The Linux Rain" />
  <meta property="og:description" content="Several of my data-auditing scripts take a long time to execute. Until recently I had no way of knowing how long they'd take. I'd enter the command for the script, press Enter and wait. And wait. I've now discovered the pipeline viewer or pv command, which tracks the progress of my scripts." />
  <meta property="og:url" content="http://www.thelinuxrain.com/articles/when-will-this-script-finish-doing-its-job" />
  <meta property="og:image" content="http://www.thelinuxrain.com/content/01-articles/199-when-will-this-script-finish-doing-its-job/headimage.jpg" />

    <meta property="article:section" content="Tutorials" />
  
      <meta property="article:tag" content="scripting" />
    <meta property="article:tag" content="pv" />
    <meta property="article:tag" content="cli" />
    <meta property="article:tag" content="commandline" />
    <meta property="article:tag" content="tutorials" />
    
    <meta property="article:published_time" content="2017-12-01T18:30:00+00:00" />
  
</head>

<body id="page" class=" article">

<header id="main-header">
	<a href="http://www.thelinuxrain.com"><h1 class="text-center">
	The Linux Rain	<small class="clearfix">Linux General/Gaming News, Reviews and Tutorials</small>
	</h1>
	</a>
</header>
 <nav id="navbar-main" class="navbar navbar-inverse" role="navigation">
	<div class="container-fluid">
		 <div class="navbar-header">
		      <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1">
			<span class="sr-only">Toggle navigation</span>
			<span class="icon-bar"></span>
			<span class="icon-bar"></span>
			<span class="icon-bar"></span>
		      </button>
		</div>
			<div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
			<ul class="nav navbar-nav">        <li><a class="is-active" href="http://www.thelinuxrain.com">Home</a></li>
        <li><a href="http://www.thelinuxrain.com/about">About</a></li>
        <li><a href="http://www.thelinuxrain.com/contact">Contact</a></li>
        <li><a href="http://www.thelinuxrain.com/submit-an-article">Submit Tip/Article</a></li>
    <li class="dropdown-eligible"><a href="#categories">Categories</a><ul class="sub-menu">
		
			<li><a href="http://www.thelinuxrain.com/category:Reviews">Reviews</a></li>
			<li><a href="http://www.thelinuxrain.com/category:News">News</a></li>
			<li><a href="http://www.thelinuxrain.com/category:Tutorials">Tutorials</a></li>
			<li><a href="http://www.thelinuxrain.com/category:Editorials">Editorials</a></li>
			<li><a href="http://www.thelinuxrain.com/category:Announcements">Announcements</a></li>
			<li><a href="http://www.thelinuxrain.com/category:Previews">Previews</a></li>
			<li><a href="http://www.thelinuxrain.com/category:Upcoming">Upcoming</a></li>
			<li><a href="http://www.thelinuxrain.com/category:Advocacy">Advocacy</a></li>
			<li><a href="http://www.thelinuxrain.com/category:Overviews">Overviews</a></li>
	</ul>
</li></ul>
		</div> <!-- /.navbar-collapse -->
	</div> <!-- /.container-fluid -->
</nav>
<div class="container-fluid">
<div class="main">
<div class="article-content">
				<header>
					<img class="img-responsive center-block" src="http://www.thelinuxrain.com/content/01-articles/199-when-will-this-script-finish-doing-its-job/headimage.jpg">
					<h1 class="text-center">When will this script finish doing its job?</h1>
					<h4 class="text-center">By <span class="text-uppercase">Bob Mesibov</span>, published 01/12/2017 in <a href="http://www.thelinuxrain.com/category:Tutorials">Tutorials</a></h4>
				</header>
					<hr>
				<div class="article-inner-content">
					<p>Several of my data-auditing scripts take a long time to execute. Until recently I had no way of knowing how long they'd take. I'd enter the command for the script, press <em>Enter</em> and wait. And wait.</p>
<p>I've now discovered the <em>pipeline viewer</em> or <a href="https://linux.die.net/man/1/pv"><strong>pv</strong> command</a>, which tracks the progress of my scripts.</p>
<p>An example script is <strong>gremlins2</strong>, described on my <a href="https://www.polydesmida.info/cookbook/gremlins.html">data-cleaning website</a>. The script looks in a text file for non-printing characters other than space, horizontal tab, soft hyphen and non-breaking space, then tallies the various invisible characters it finds and gives their hexadecimal values. The command takes the filename as its one argument.</p>
<p>To run <strong>gremlins2</strong> on the 250+ MB file <em>refs0</em>, which contains a total of 263,737,236 characters, I just enter &quot;gremlins2 refs0&quot; in a terminal. And wait.</p>
<p>To follow the progress of the script with <strong>pv</strong> I have a couple of choices. One is to use <strong>pv</strong> like <strong>cat</strong> and pipe <em>refs0</em> to <strong>gremlins2</strong>, like this:</p>
<pre><code>pv refs0 | gremlins2</code></pre>
<p>My preferred options for <strong>pv</strong> are &quot;-p&quot;, which generates a simple progress bar; &quot;-b&quot;, which reports the number of bytes processed; &quot;-t&quot;, which keeps track of elapsed time; and &quot;-w 50&quot;, which constrains the <strong>pv</strong> output in my terminal to a width of 50 characters. So:</p>
<pre><code>pv -w 50 -pbt refs0 | gremlins2</code></pre>
<p>And here's what I see after the process has finished:</p>
<figure><img src="http://www.thelinuxrain.com/content/01-articles/199-when-will-this-script-finish-doing-its-job/1.png" alt=""></figure>
<p>Does running <strong>pv</strong> slow down the overall process? Not according to the <strong>time</strong> command:</p>
<figure><img src="http://www.thelinuxrain.com/content/01-articles/199-when-will-this-script-finish-doing-its-job/2.png" alt=""></figure>
<p>A second way to use <strong>pv</strong> is to incorporate it into a script. In other words, instead of</p>
<pre><code>pv filename | command-in-script "$1"</code></pre>
<p>you have the first line of the script saying</p>
<pre><code>pv "$1" | command-in-script</code></pre>
<p>Here's the result of running a version of the <strong>gremlins2</strong> script with <strong>pv</strong> included:</p>
<figure><img src="http://www.thelinuxrain.com/content/01-articles/199-when-will-this-script-finish-doing-its-job/3.png" alt=""></figure>
<p>So how come I'd never heard of this excellent <strong>pv</strong> program before? (Scratches grey beard in puzzlement...)</p>
<hr />
<p>Top image by &quot;btr&quot; from <a href="https://commons.wikimedia.org/wiki/File:Pipeline_(im_Bau).jpg">Wikimedia Commons</a></p>					<hr>
<div class="share-links">
	<h4>Share This</h4>
	<a class="googleplus" href="https://plus.google.com/share?url=http%3A%2F%2Fwww.thelinuxrain.com%2Farticles%2Fwhen-will-this-script-finish-doing-its-job">Google+</a>
	<a class="twitter" href="https://twitter.com/share?url=http%3A%2F%2Fwww.thelinuxrain.com%2Farticles%2Fwhen-will-this-script-finish-doing-its-job&text=When+will+this+script+finish+doing+its+job%3F" class="button">Twitter</a>
	<a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.thelinuxrain.com%2Farticles%2Fwhen-will-this-script-finish-doing-its-job">Facebook</a>
</div>
					<div class="about-author"><hr />
<h4>About the Author</h4>
<p>Bob Mesibov is Tasmanian, retired and a keen Linux tinkerer.</p></div>										<span class="tags">Tags:
											<a href="/tag:scripting">scripting</a>
											<a href="/tag:pv">pv</a>
											<a href="/tag:cli">cli</a>
											<a href="/tag:commandline">commandline</a>
											<a href="/tag:tutorials">tutorials</a>
									</span>
				</div> <!-- /.article-inner-content -->
			<div id="disqus_container">
								<div id="disqus_thread"></div>
<script type="text/javascript">
  var disqus_shortname  = 'thelinuxrain'; // required: replace example with your forum shortname
  var disqus_title      = 'When will this script finish doing its job?';
  var disqus_developer  = 'false'; // developer mode
  var disqus_identifier = 'articles/when-will-this-script-finish-doing-its-job';
  var disqus_url        = 'http://www.thelinuxrain.com/articles/when-will-this-script-finish-doing-its-job';

  (function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
    dsq.src = 'http://' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
  })();
</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<a href="http://disqus.com" class="dsq-brlink">blog comments powered by <span class="logo-disqus">Disqus</span></a>
			</div>
			</article>
</div> <!-- /.article-content -->
<aside class="right-sidebar">
	<section>
	<form action="http://www.thelinuxrain.com/search">
			<div class="input-group">
				<input class="form-control search-field" type="text" name="q" placeholder="Search..." />
				<span class="input-group-btn">
					<input class="btn search-submit" type="submit" value="" />
				</span>
			</div>
		</form>
	</section>

	<section>
		<h4>Follow Us</h4>
		<div class="social-follow-buttons">
		<a href="https://facebook.com/thelinuxrain" target="_blank"><span class="social-button btn-facebook"></span></a>
		<a href="https://twitter.com/intent/user?screen_name=TheLinuxRain" target="_blank"><span class="social-button btn-twitter"></span></a>
		<a href="http://plus.google.com/105314050105739144609?prsrc=3" target="_blank"><span class="social-button btn-google"></span></a>
		<a href="feed" target="_blank"><span class="social-button btn-rss"></span></a>
		</div>

	</section>

	<section>
		<h4>Recent Articles</h4>
		<div class="widget_recent_entries">
			<ul class="sidebar-links">

			<li>
				<a href="http://www.thelinuxrain.com/articles/when-will-this-script-finish-doing-its-job">When will this script finish doing its job?</a>
			</li>


			<li>
				<a href="http://www.thelinuxrain.com/articles/how-to-run-diablo-2-glide-opengl-wrapper">How to Run Diablo II with the GLIDE-to-OpenGL Wrapper</a>
			</li>


			<li>
				<a href="http://www.thelinuxrain.com/articles/layers-of-fear-more-like-layers-of-jumpscares-byte-size-review">Layers of Fear - more like Layers of Jumpscares</a>
			</li>


			<li>
				<a href="http://www.thelinuxrain.com/articles/a-simpler-track-changes-script">A simpler track-changes script</a>
			</li>


			<li>
				<a href="http://www.thelinuxrain.com/articles/a-script-to-toggle-cpu-performance-governor">A Script to Toggle the CPU Performance Governor</a>
			</li>


			<li>
				<a href="http://www.thelinuxrain.com/articles/file-manager-open-a-terminal-but-not-here">File manager: open a terminal, but not here</a>
			</li>


			<li>
				<a href="http://www.thelinuxrain.com/articles/void-linux-the-little-distro-that-could">Void Linux, the Little Distro That Could</a>
			</li>


			<li>
				<a href="http://www.thelinuxrain.com/articles/shifty-dates-in-microsoft-excel">Shifty dates in Microsoft Excel</a>
			</li>


			<li>
				<a href="http://www.thelinuxrain.com/articles/it-rains-pretty-regularly-in-the-shell">It rains pretty regularly, in the shell</a>
			</li>


			<li>
				<a href="http://www.thelinuxrain.com/articles/how-to-suspend-from-the-command-line">Quick Tip: How to Suspend from the Command Line</a>
			</li>

</ul>
			</div>
	</section>
	<section>
		<h4>Editor Picks</h4>
		<div class="widget_recent_entries">
			
<ul class="sidebar-links">

	<li> <a href="http://www.thelinuxrain.com/articles/containers-a-great-privacy-add-on-currently-in-firefox-test-pilot">Containers, a Great Privacy Add-On Currently in Firefox Test Pilot</a></li>
	<li> <a href="http://www.thelinuxrain.com/articles/xfe-file-manager-an-independent-marvel">Xfe file manager: an independent marvel</a></li>

</ul>
		</div>
	</section>
	<section>
		<h4>Linux Links</h4>
		<div class="widget_recent_entries">
			
<ul class="sidebar-links">

	<li> <a href="https://www.sudosatirical.com/">Sudo Satirical</a></li>
	<li> <a href="http://www.tuxarena.com/">TuxArena</a></li>

</ul>
		</div>
	</section>
	<section>
	<a href="https://www.resetthenet.org" target="_blank"><img class="img-responsive" src="http://www.thelinuxrain.com/assets/images/take-back-reset-the-net.png"></a>
	</section>
	<section>
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- SidebarAd -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5941131116498030"
     data-ad-slot="4271339906"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
	</section>
	<section>
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- SkyscraperAd -->
<ins class="adsbygoogle"
style="display:block;width:160px;height:600px;margin:0 auto;"
data-ad-client="ca-pub-5941131116498030"
data-ad-slot="7588929504"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
	</section>
</aside>
</div> <!-- /.main -->
</div> <!-- /.container-fluid -->
<div id="bottom-ad">
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<!-- BottomAdResponsive -->
	<ins class="adsbygoogle"
		 style="display:block"
		 data-ad-client="ca-pub-5941131116498030"
		 data-ad-slot="3688184305"
		 data-ad-format="auto"></ins>
	<script>
	(adsbygoogle = window.adsbygoogle || []).push({});
	</script>
</div>
  <footer>
    	<div class="text-center"><p>© 2013-2017 The Linux Rain<br />
Powered by the <a href="http://getkirby.com">KirbyCMS</a><br />
Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.</p></div>
  </footer>
  <script src="http://www.thelinuxrain.com/js/jquery.min.js"></script>  <script src="http://www.thelinuxrain.com/js/bootstrap.min.js"></script>	<script>

	jQuery(document).ready(function($) {

		$('.dropdown-eligible').children('a').append(' <span class="caret"></span>');
		$('.dropdown-eligible').children('a').addClass('dropdown');
		$('.dropdown-eligible').children('a').attr('data-toggle', 'dropdown');
		$('.nav .sub-menu').addClass('dropdown-menu');
	});

	</script>
</body>
</html>
