<!DOCTYPE html>
<html dir="ltr" lang="en">
    <head>
	<script>
	  WebFontConfig = {
		  google: { families: ['Share Tech Mono', 'Lato:400,700'] }
	  };

	  (function() {
	    var wf = document.createElement('script');
	    wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
		      '://ajax.googleapis.com/ajax/libs/webfont/1.4.7/webfont.js';
	    wf.type = 'text/javascript';
	    wf.async = 'true';
	    var s = document.getElementsByTagName('script')[0];
	    s.parentNode.insertBefore(wf, s);
	  })();
	</script>
	<script>document.cookie='resolution='+Math.max(screen.width,screen.height)+'; path=/';</script>
<style>
body {
	font-family: 'Lato', sans-serif !important;
	background-color: #fcf8e2 !important;
}

#main-header  {
	margin-top: -20px;
	height: 150px;
	background-color: #ebf0f0;
	background-image: url("http://www.thelinuxrain.com:80/images/rain.jpg");
}

#main-header h1 {
	padding-top: 30px;
	color: #f5f5f5;
	font-family: 'Share Tech Mono';
	font-weight: bold;
}

#main-header small {
	color: #ddd;
	font-size: 56%;
}

#navbar-main {
	background-color: #fdf6e3;
	border-top: none;	
	border-left: none;	
	border-right: none;	
	border-bottom: 2px solid #ccc;
	border-radius: 0px;
	font-weight: bold;
	text-transform: uppercase;
}

#navbar-main a:hover {
	color: #cb4b16;
}

#navbar-main .current_page_item a {
	color: #268bd2;
}

.navbar-nav .open a:focus {
	background-color: #eee8d5 !important;
	color: #268bd2 !important;
}

#navbar-main .search-form {
	float: right;
}

#navbar-main .search-field {
	height: 30px;
}

#navbar-main .search-field, #navbar-main .search-submit {
	display: none;
}

#navbar-main .search-submit {
	margin-top: 3px;
}

.navbar-toggle {
	border-radius: 0px;
}

.navbar-toggle .icon-bar {
	background-color: #555 !important;
}

.navbar-toggle:hover .icon-bar {
	background-color: #fff !important;
}

.social-follow-buttons .btn {
	width: 50%;
	background-color: #ccc;
	margin-top: 2px;
	color: #3C5259;
}

.social-follow-buttons {
	text-align: center;
}

.social-button {
	height: 32px;
	width: 32px;
	display: inline-block;
	opacity: 0.5;
	margin: 5px 10px 5px 10px;
}

.social-button:hover {
	opacity: 1;
	transition: opacity 0.3s;
}

.btn-twitter {
	background-image: url("http://www.thelinuxrain.com:80/images/twitter.png");
}

.btn-google {
	background-image: url("http://www.thelinuxrain.com:80/images/googleplus.png");
}

.btn-facebook {
	background-image: url("http://www.thelinuxrain.com:80/images/facebook1.png");
}

.btn-rss {
	background-image: url("http://www.thelinuxrain.com:80/images/rss.png");
}

.main {
	max-width: 1140px;
	margin: 0 auto;
}

.articles-box {
	float: left;
	width: 70%;
}

.article-title {
	font-family: 'Lato', sans-serif;
	font-size: 24px;
	color: #002b26;
}

.article-title:hover {
	color: #cb4b16;
}

.article-seperator {
	margin-top: 10px;
	margin-bottom: 10px;
	border: none;
}

.featured-tag {
	position: absolute;
	top: 0px;
	left: 0px;
	color: #f5f5f5;
	background-color: #268bd2;
	padding: 5px;
	font-family: 'Share Tech Mono';
	font-weight: bold;
}

.featured-tag:after {
	content: "LATEST";
}


.article-container {
	position: relative;
	height: 350px;
	overflow: hidden;
	padding: 20px;
	background-color: #eee8d5;
	border-bottom: 2px solid #ccc;
	border-top: 1px solid #ddd;
	border-right: 1px solid #ddd;
	border-left: 1px solid #ddd;
}

.article-featured-container {
	background-color: #eee8d5;
}

.article-content {
	float: left;
	font-family: 'Lato', sans-serif;
	padding: 20px;
	width: 70%;
	background-color: #eee8d5;
	border-bottom: 2px solid #ccc;
	border-top: 1px solid #ddd;
	border-right: 1px solid #ddd;
	border-left: 1px solid #ddd;
}

.article-date {
	margin-left: 5px;
	font-size: 90%;
}

.article-excerpt {
	color: #101010;
	font-family: 'Lato', sans-serif;
}

.article-inner-content {
	margin-top: 20px;
}

.article-inner-content p {
	color: #101010;
	line-height: 28px;
}

.article-inner-content img {
	max-width: 100%;
	height: auto;
	display: block;
	margin: 10px auto;
}

.article-author {
	color: #555;
}

.article-category {
	color: #428ed9;
	font-weight: bold;
}

.msnry-box {
	margin-top: 10px;
	margin-right: -3px;
	display: inline-block;
	vertical-align: top;
	float: none !important;
	height: auto;
}

.author-and-date {
	font-size: 110%;
}

.sub-menu {
	display: none;
}

</style>
  <meta name="google-site-verification" content="mPIuLMMAukIaLD0bpwui4JfmjlaAm_pPqvWhcuXCd48" />
  <title>Tips for tpp and patat | The Linux Rain</title>
  <meta charset="UTF-8">

    <meta name="description" content="You might be surprised to learn that there are programs for running presentations in a terminal. No, I don't mean opening PowerPoint or Impress slides one after the other, as images in a frame-buffered console. I mean presenting slides coded for the terminal, in a terminal. Interesting idea? It seems to be, because there are (at least) 8 terminal presentation programs for Linux:" />
  
  	<meta name="keywords" content="linux, gaming, steam, reviews, news, tutorials" />
   
  <meta name="robots" content="index, follow">
  <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

  <link rel="shortcut icon" href="http://www.thelinuxrain.com:80/assets/images/favicon.gif" type="image/gif" />
  <link rel="icon" href="http://www.thelinuxrain.com:80/assets/images/favicon.gif" type="image/gif" />
  <link rel="shortlink" type="text/html" href="http://www.thelinuxrain.com:80/x/1lc4gnc">


  <!--[if lt IE 9]>
	<script src="http://www.thelinuxrain.com:80/assets/dist/html5shiv.js"></script>  <![endif]-->

  <meta property="og:site_name" content="The Linux Rain" />
  <meta property="og:type" content="article" />
  <meta property="og:title" content="Tips for tpp and patat | The Linux Rain" />
  <meta property="og:description" content="You might be surprised to learn that there are programs for running presentations in a terminal. No, I don't mean opening PowerPoint or Impress slides one after the other, as images in a frame-buffered console. I mean presenting slides coded for the terminal, in a terminal. Interesting idea? It seems to be, because there are (at least) 8 terminal presentation programs for Linux:" />
  <meta property="og:url" content="http://www.thelinuxrain.com:80/articles/tips-for-tpp-and-patat" />
  <meta property="og:image" content="http://www.thelinuxrain.com:80/thumbs/headimage-a2e4eab3d1a46c2d8788a72bc499d27b.jpg" />

    <meta property="article:section" content="Tutorial" />
  
      <meta property="article:tag" content="tutorial" />
    <meta property="article:tag" content="scripts" />
    <meta property="article:tag" content="tpp" />
    <meta property="article:tag" content="patat" />
    <meta property="article:tag" content="console" />
    <meta property="article:tag" content="bash" />
    <meta property="article:tag" content="presentations" />
    
    <meta property="article:published_time" content="2017-02-22T22:00:00+00:00" />
  
</head>

<body id="page" class=" article">
   <script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', 'UA-46481365-1', 'thelinuxrain.com');
	  ga('send', 'pageview');

  </script>
<header id="main-header">
	<a href="http://www.thelinuxrain.com:80"><h1 class="text-center">
	The Linux Rain	<small class="clearfix">Linux General/Gaming News, Reviews and Tutorials</small>
	</h1>
	</a>
</header>
 <nav id="navbar-main" class="navbar navbar-inverse" role="navigation">
	<div class="container-fluid">
		 <div class="navbar-header">
		      <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1">
			<span class="sr-only">Toggle navigation</span>
			<span class="icon-bar"></span>
			<span class="icon-bar"></span>
			<span class="icon-bar"></span>
		      </button>
		</div>
			<div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
			<ul class="nav navbar-nav">        <li><a class="is-active" href="http://www.thelinuxrain.com:80">Home</a></li>
        <li><a href="http://www.thelinuxrain.com:80/about">About</a></li>
        <li><a href="http://www.thelinuxrain.com:80/contact">Contact</a></li>
        <li><a href="http://www.thelinuxrain.com:80/submit-an-article">Submit Tip/Article</a></li>
    <li class="dropdown-eligible"><a href="#categories">Categories</a><ul class="sub-menu">
		
			<li><a href="http://www.thelinuxrain.com:80/category:Reviews">Reviews</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:News">News</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Tutorials">Tutorials</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Editorials">Editorials</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Announcements">Announcements</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Previews">Previews</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Upcoming">Upcoming</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Advocacy">Advocacy</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Overviews">Overviews</a></li>
	</ul>
</li></ul>
		</div> <!-- /.navbar-collapse -->
	</div> <!-- /.container-fluid -->
</nav>
<div class="container-fluid">
<div class="main">
<div class="article-content">
				<header>
					<img class="img-responsive center-block" src="http://www.thelinuxrain.com:80/content/01-articles/138-tips-for-tpp-and-patat/headimage.jpg">
					<h1 class="text-center">Tips for tpp and patat</h1>
					<h4 class="text-center">By <span class="text-uppercase">Bob Mesibov</span>, published 22/02/2017</h4>
				</header>
					<hr>
				<div class="article-inner-content">
					<p>You might be surprised to learn that there are programs for running presentations in a terminal.</p>
<p>No, I don't mean opening PowerPoint or Impress slides one after the other, as images in a frame-buffered console. I mean presenting slides coded for the terminal, in a terminal.</p>
<p>Interesting idea? It seems to be, because there are (at least) 8 terminal presentation programs for Linux:</p>
<ul>
<li><a href="https://github.com/kittikjs/kittik">kittik</a></li>
<li><a href="https://github.com/visit1985/mdp">mdp</a></li>
<li><a href="https://github.com/jaspervdj/patat">patat</a></li>
<li><a href="https://github.com/mcrio/tiptip">tiptip</a></li>
<li><a href="https://github.com/fxn/tkn">tkn</a></li>
<li><a href="https://github.com/porras/tkn2">tkn2</a></li>
<li><a href="https://github.com/akrennmair/tpp">tpp</a></li>
<li><a href="https://github.com/alampros/vtmc">vtmc</a></li>
</ul>
<p>I haven't tried them all, but I've found <strong>tpp</strong> and <strong>patat</strong> to be fairly easy to use. Below are a few tips on working with these two programs.</p>
<p>Note that neither <strong>tpp</strong> nor <strong>patat</strong> presentation files need a filename suffix. The one argument for the <strong>tpp</strong> or <strong>patat</strong> command to start a presentation is  the name of a text file, or the path to that filename if you're in another directory. The filename doesn't need a suffix, and the same presentation text file will run as <em>pres</em>, <em>pres.txt</em>, <em>pres.pdf</em> or <em>pres.whateveryoulike</em>. It makes sense, though, to name a <strong>tpp</strong> presentation with the filename suffix <em>.tpp</em>, or a <strong>patat</strong> presentation with the suffix <em>.patat</em>, so you can find the file more easily and remember what it is.</p>
<h1>tpp</h1>
<p><strong>tpp</strong> is a 41 kB Ruby script written by Andreas Krennmair (author of the popular <a href="http://www.newsbeuter.org/">newsbeuter</a> RSS reader) and Nico Golde, and it presents slides in ncurses. To try it out, install the latest version (currently 1.3.1) from your Linux repository. See the README that comes with <strong>tpp</strong> for full instructions on its use. Example files come with <strong>tpp</strong>, and these are also on GitHub <a href="https://github.com/akrennmair/tpp/tree/master/examples">here</a>.</p>
<p>With <strong>tpp</strong> you're not stuck with the default ncurses background colours, which are black, blue, cyan, green, magenta, red, white and yellow. You can set any one of these for your presentation with the <em>--bgcolor</em> global option, for example</p>
<pre><code>--bgcolor cyan</code></pre>
<p>but <strong>tpp</strong> also has the option</p>
<pre><code>--bgcolor default</code></pre>
<p>which makes the background transparent, and gives it the background colour of your terminal. If your terminal itself is transparent, for example over a desktop wallpaper, that wallpaper will be the slide background:</p>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/138-tips-for-tpp-and-patat/1.png" alt="1" /></figure>
<p>According to the documentation and one of Krennmair's <a href="https://github.com/akrennmair/tpp/blob/master/examples/exec.tpp">examples</a>, you can run a shell command within <strong>tpp</strong> by using the "--exec" option. This doesn't work with my kernel's default settings (3.16.0, Debian 8) and I get a <strong>tpp</strong> error message on the slide: <em>--exec disabled by default for security reasons. Use option -x to enable it.</em> Adding option "-x" to the <strong>tpp</strong> command (as in <em>tpp -x file</em>) removes the error message from the slide, but the shell command following <strong>exec</strong> still isn't launched.</p>
<p>While it would be cool to launch a command from a presentation slide, <strong>tpp</strong> offers another way to show commands and their results. If you use the "beginshelloutput/endshelloutput" option and prefix your command with "$", then <strong>tpp</strong> prints that line character by character, as though you were typing it. The lines that follow can be the expected command output, and all of this will "shell output" be framed by dashes. Here's the example slide shown in the screenshot above; save it as <em>file</em> and run <em>tpp file</em>:</p>
<pre><code>--bgcolor default
--boldon
An example of faking a command:

--beginshelloutput

$ echo -e  "aaa\nbbb\nccc"
aaa
bbb
ccc

$ echo -e  "aaa\nbbb\nccc" | tr '\n' ','
aaa,bbb,ccc

--endshelloutput
--boldoff</code></pre>
<h1>patat</h1>
<p><strong>patat</strong> is a massive (43 MB) executable written in Haskell by Jasper Van der Jeugt, and it relies on a range of Haskell libraries instead of ncurses. If you're running Debian 9 you're in luck, because there's a <strong>patat</strong> package in the repository. If like me you're running an earlier Debian base, you'll need to build <strong>patat</strong> from source. There are full instructions for that <a href="https://github.com/jaspervdj/patat#from-source">here</a>, on the same webpage as the <strong>patat</strong> how-to.</p>
<p>You can't center a line of text on a slide with <strong>patat</strong>, as you can with <strong>tpp</strong>. I also haven't been able to get <strong>patat</strong>'s syntax highlighting of code to work. This may be because I haven't got all of <strong>kate</strong>'s KDE libraries on my Xfce setup, or it may be an issue with the code for character colouring on my Xfce terminal.</p>
<p>Why, then, would I use <strong>patat</strong> instead of <strong>tpp</strong> for simple text slides? Because it does <em>tables</em>! With <em>column alignment</em>! (See below.)</p>
<p>The default styling in <strong>patat</strong> seems to be based on Ethan Schoonover's <a href="http://ethanschoonover.com/solarized">solarized</a> theme. Here's how a sample slide looks in my Xfce4 terminal, which I like to show yellow text on a dark green (#004400) background. (I've shrunk the terminal window to make the screenshot smaller.) Note that the comment line is ignored.</p>
<pre><code>---
author: 'Bob Mesibov'
title: 'This is the title'
...

#This is a header

[comment]: # This is a comment

This is *emph text*

This is **bold text**

This is `code text`

Here is a code block:

    line of code
    another line of code</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/138-tips-for-tpp-and-patat/2.png" alt="2" /></figure>
<p>As you can see, <strong>patat</strong> understands simple Markdown. You can also style some of the elements of a slide in the header section of the presentation, which is started off by a line with three dashes and is closed by a line of three periods. Here I've made the header white and bold, brightened the emphasised text and changed how code is presented:</p>
<pre><code>---
author: 'Bob Mesibov'
title: 'This is the title'
patat:
    theme:
        header: [vividWhite,bold]
        emph: [vividGreen]
        code: [dullBlack,onDullWhite]
        codeBlock: [dullBlack,onDullWhite]
...

#This is a header

[comment]: # This is a comment

This is *emph text*

This is **bold text**

This is `code text`

Here is a code block:

    line of code
    another line of code</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/138-tips-for-tpp-and-patat/3.png" alt="3" /></figure>
<p>To display tables in <strong>patat</strong>, just set the cells off with pipes and put a line of pipe-separated dashes under the header line (see code below). You can also align cell elements by putting a colon or two in the line of dashes. A colon on the left of the dashes (or no colon) means left-aligned, colons left and right mean centered, and a colon at the right means right-aligned. The table is slightly indented.</p>
<pre><code>Here's a table:

| Heading 1 | Longer heading 2 | Hdg 3 |
| --- | :---: | ---: |
| Item 1 | a fairly long, centered string | 23 |
| Item 2 | also centered | 161003 |</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/138-tips-for-tpp-and-patat/4.png" alt="4" /></figure>
<p>Another problem I've had with <strong>patat</strong> is that if there's no title for the presentation in the header section, then <strong>patat</strong> always puts the first line of text at the very top of the terminal window. Blank lines and comment lines are respected after that first line of text, but ignored if they appear before it. The only workaround I've found is to insert a header line (with or without following blank lines) before the first line of text, and to colour the header line (styled in the header section) with the same colour as the slide background. This makes the header line invisible and drops the first line of text.</p>
<p>[Top <a href="https://commons.wikimedia.org/wiki/File:BarCampBournemouth_3_Powerpoint_Karaoke.jpg">image</a> by Tom Morris, from a 2011 PowerPoint Karaoke session: speakers present a slide show chosen by other people, and have to pretend they know what the slides are about!]</p>					<div class="about-author"><hr />
<h4>About the Author</h4>
<p>Bob Mesibov is Tasmanian, retired and a keen Linux tinkerer.</p></div>										<span class="tags">Tags:
											<a href="/tag:tutorial">tutorial</a>
											<a href="/tag:scripts">scripts</a>
											<a href="/tag:tpp">tpp</a>
											<a href="/tag:patat">patat</a>
											<a href="/tag:console">console</a>
											<a href="/tag:bash">bash</a>
											<a href="/tag:presentations">presentations</a>
									</span>
				</div> <!-- /.article-inner-content -->
			<div id="disqus_container">
								<div id="disqus_thread"></div>
<script type="text/javascript">
  var disqus_shortname  = 'thelinuxrain'; // required: replace example with your forum shortname
  var disqus_title      = "Tips for tpp and patat";
  var disqus_developer  = 'false'; // developer mode
  var disqus_identifier = 'articles/tips-for-tpp-and-patat';
  var disqus_url        = 'http://www.thelinuxrain.com:80/articles/tips-for-tpp-and-patat';

  (function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
    dsq.src = 'http://' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
  })();
</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<a href="http://disqus.com" class="dsq-brlink">blog comments powered by <span class="logo-disqus">Disqus</span></a>
			</div>
			</article>
</div> <!-- /.article-content -->
<aside class="right-sidebar">
	<section>
		<form role="search" action="http://www.google.com" id="cse-search-box">
	 <div class="google-search-box">
		<div class="input-group">
			<input type="hidden" name="cx" value="partner-pub-5941131116498030:3231598707" />
			<input type="hidden" name="ie" value="UTF-8" />
			<input class="form-control search-field" type="text" name="q" />
			<span class="input-group-btn">
				<input class="btn search-submit" type="submit" name="sa" value="" />
			</span>
		</div>
	</div>
</form>
<script type="text/javascript" src="http://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
	</section>
	
	<section>
		<h4>Follow Us</h4>
		<div class="social-follow-buttons">
		<a href="https://facebook.com/thelinuxrain" target="_blank"><span class="social-button btn-facebook"></span></a>
		<a href="https://twitter.com/intent/user?screen_name=TheLinuxRain" target="_blank"><span class="social-button btn-twitter"></span></a>
		<a href="http://plus.google.com/105314050105739144609?prsrc=3" target="_blank"><span class="social-button btn-google"></span></a>
		<a href="feed" target="_blank"><span class="social-button btn-rss"></span></a>
		</div>

	</section>
	<section>
		<h4>Recent Articles</h4>
		<div class="widget_recent_entries">
			<ul class="sidebar-links">
			
			<li>
				<a href="http://www.thelinuxrain.com:80/articles/tips-for-tpp-and-patat">Tips for tpp and patat</a>
			</li>
			
			
			<li>
				<a href="http://www.thelinuxrain.com:80/articles/hitman-on-linux-first-impressions">HITMAN on Linux - First Impressions</a>
			</li>
			
			
			<li>
				<a href="http://www.thelinuxrain.com:80/articles/all-7-aveyond-games-released-for-linux-drm-free">All 7 Aveyond Games Released for Linux, DRM-Free</a>
			</li>
			
			
			<li>
				<a href="http://www.thelinuxrain.com:80/articles/getting-realtek-8188eu-wireless-adapters-to-work-in-linux-and-possibly-other-wireless-realtek-chipsets">Getting Realtek 8188EU Wireless Adapters to work in Linux (and possibly other wireless Realtek chipsets!)</a>
			</li>
			
			
			<li>
				<a href="http://www.thelinuxrain.com:80/articles/scottish-country-dancing-stats">Scottish Country Dancing stats</a>
			</li>
			
</ul>
			</div>
	</section>
	<section>
		<h4>Editor Picks</h4>
		<div class="widget_recent_entries">
			
<ul class="sidebar-links">

	<li> <a href="http://www.thelinuxrain.com:80/articles/proofreading-for-illusions-with-grep-and-awk">Proofreading for illusions with grep and AWK</a></li>
	<li> <a href="http://www.thelinuxrain.com:80/articles/tutorial-how-to-use-kwin-window-manager-with-xfce">Tutorial: How to use the KWin Window Manager with Xfce</a></li>

</ul>
		</div>
	</section>
	<section>
		<h4>Linux Links</h4>
		<div class="widget_recent_entries">
			
<ul class="sidebar-links">

	<li> <a href="http://www.tuxarena.com/">TuxArena</a></li>

</ul>
		</div>
	</section>
	<section>
	<a href="https://www.resetthenet.org" target="_blank"><img class="img-responsive" src="http://www.thelinuxrain.com:80/assets/images/take-back-reset-the-net.png"></a>
	</section>
	<section>
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- SidebarAd -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5941131116498030"
     data-ad-slot="4271339906"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
	</section>
	<section>
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- SkyscraperAd -->
<ins class="adsbygoogle"
style="display:block;width:160px;height:600px;margin:0 auto;"
data-ad-client="ca-pub-5941131116498030"
data-ad-slot="7588929504"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
	</section>
</aside>
</div> <!-- /.main -->
</div> <!-- /.container-fluid -->
<div id="bottom-ad">
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<!-- BottomAdResponsive -->
	<ins class="adsbygoogle"
		 style="display:block"
		 data-ad-client="ca-pub-5941131116498030"
		 data-ad-slot="3688184305"
		 data-ad-format="auto"></ins>
	<script>
	(adsbygoogle = window.adsbygoogle || []).push({});
	</script>
</div>
  <footer>
    	<div class="text-center"><p>© 2013-2016 The Linux Rain <br />
Powered by the <a href="http://getkirby.com">KirbyCMS</a><br />
Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.</p></div>
  </footer>
  <link rel="stylesheet" href="http://www.thelinuxrain.com:80/css/bootstrap.min.css?v=2" />  <link rel="stylesheet" href="http://www.thelinuxrain.com:80/css/style.css?v=20" />  <script src="http://www.thelinuxrain.com:80/js/jquery.min.js"></script>  <script src="http://www.thelinuxrain.com:80/js/bootstrap.min.js"></script>	<script>

	jQuery(document).ready(function($) {

		$('.dropdown-eligible').children('a').append(' <span class="caret"></span>');
		$('.dropdown-eligible').children('a').addClass('dropdown');
		$('.dropdown-eligible').children('a').attr('data-toggle', 'dropdown');
		$('.nav .sub-menu').addClass('dropdown-menu');
	});

	</script>
</body>
</html>
