<!DOCTYPE html>
<html dir="ltr" lang="en">
    <head>
	<script>
	  WebFontConfig = {
		  google: { families: ['Share Tech Mono', 'Lato:400,700'] }
	  };

	  (function() {
	    var wf = document.createElement('script');
	    wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
		      '://ajax.googleapis.com/ajax/libs/webfont/1.4.7/webfont.js';
	    wf.type = 'text/javascript';
	    wf.async = 'true';
	    var s = document.getElementsByTagName('script')[0];
	    s.parentNode.insertBefore(wf, s);
	  })();
	</script>
	<script>document.cookie='resolution='+Math.max(screen.width,screen.height)+'; path=/';</script>
<style>
body {
	font-family: 'Lato', sans-serif !important;
	background-color: #fcf8e2 !important;
}

#main-header  {
	margin-top: -20px;
	height: 150px;
	background-color: #ebf0f0;
	background-image: url("http://www.thelinuxrain.com:80/images/rain.jpg");
}

#main-header h1 {
	padding-top: 30px;
	color: #f5f5f5;
	font-family: 'Share Tech Mono';
	font-weight: bold;
}

#main-header small {
	color: #ddd;
	font-size: 56%;
}

#navbar-main {
	background-color: #fdf6e3;
	border-top: none;
	border-left: none;
	border-right: none;
	border-bottom: 2px solid #ccc;
	border-radius: 0px;
	font-weight: bold;
	text-transform: uppercase;
}

#navbar-main a:hover {
	color: #cb4b16;
}

#navbar-main .current_page_item a {
	color: #268bd2;
}

.navbar-nav .open a:focus {
	background-color: #eee8d5 !important;
	color: #268bd2 !important;
}

#navbar-main .search-form {
	float: right;
}

#navbar-main .search-field {
	height: 30px;
}

#navbar-main .search-field, #navbar-main .search-submit {
	display: none;
}

#navbar-main .search-submit {
	margin-top: 3px;
}

.navbar-toggle {
	border-radius: 0px;
}

.navbar-toggle .icon-bar {
	background-color: #555 !important;
}

.navbar-toggle:hover .icon-bar {
	background-color: #fff !important;
}

.social-follow-buttons .btn {
	width: 50%;
	background-color: #ccc;
	margin-top: 2px;
	color: #3C5259;
}

.social-follow-buttons {
	text-align: center;
}

.social-button {
	height: 32px;
	width: 32px;
	display: inline-block;
	opacity: 0.5;
	margin: 5px 10px 5px 10px;
}

.social-button:hover {
	opacity: 1;
	transition: opacity 0.3s;
}

.btn-twitter {
	background-image: url("http://www.thelinuxrain.com:80/images/twitter.png");
}

.btn-google {
	background-image: url("http://www.thelinuxrain.com:80/images/googleplus.png");
}

.btn-facebook {
	background-image: url("http://www.thelinuxrain.com:80/images/facebook1.png");
}

.btn-rss {
	background-image: url("http://www.thelinuxrain.com:80/images/rss.png");
}

.main {
	max-width: 1140px;
	margin: 0 auto;
}

.articles-box {
	float: left;
	width: 70%;
}

.article-title {
	font-family: 'Lato', sans-serif;
	font-size: 24px;
	color: #002b26;
}

.article-title:hover {
	color: #cb4b16;
}

.article-seperator {
	margin-top: 10px;
	margin-bottom: 10px;
	border: none;
}

.featured-tag {
	position: absolute;
	top: 0px;
	left: 0px;
	color: #f5f5f5;
	background-color: #268bd2;
	padding: 5px;
	font-family: 'Share Tech Mono';
	font-weight: bold;
}

.featured-tag:after {
	content: "LATEST";
}


.article-container {
	position: relative;
	height: 350px;
	overflow: hidden;
	padding: 20px;
	background-color: #eee8d5;
	border-bottom: 2px solid #ccc;
	border-top: 1px solid #ddd;
	border-right: 1px solid #ddd;
	border-left: 1px solid #ddd;
}

.article-featured-container {
	background-color: #eee8d5;
}

.article-content {
	float: left;
	font-family: 'Lato', sans-serif;
	padding: 20px;
	width: 70%;
	background-color: #eee8d5;
	border-bottom: 2px solid #ccc;
	border-top: 1px solid #ddd;
	border-right: 1px solid #ddd;
	border-left: 1px solid #ddd;
}

.article-date {
	margin-left: 5px;
	font-size: 90%;
}


.article-excerpt {
	color: #101010;
	font-family: 'Lato', sans-serif;
}

.article-inner-content {
	margin-top: 20px;
}

.article-inner-content p {
	color: #101010;
	line-height: 28px;
}

.article-inner-content img {
	max-width: 100%;
	height: auto;
	display: block;
	margin: 10px auto;
}

.article-author {
	color: #555;
}

.article-category {
	color: #268bd2;
	font-weight: bold;
	margin-left: 10px;
	padding: 5px;
	background: #ddd;
}

.msnry-box {
	margin-top: 10px;
	margin-right: -3px;
	display: inline-block;
	vertical-align: top;
	float: none !important;
	height: auto;
}

.author-and-date {
	font-size: 110%;
}

.sub-menu {
	display: none;
}

</style>
  <meta name="google-site-verification" content="mPIuLMMAukIaLD0bpwui4JfmjlaAm_pPqvWhcuXCd48" />
  <title>The buttons of YAD | The Linux Rain</title>
  <meta charset="UTF-8">

    <meta name="description" content="I use the YAD dialog program quite a lot in my shell scripts. Written and maintained by Victor Ananjevksy, YAD is easy to use and has dozens of handy options." />
  
  	<meta name="keywords" content="linux, gaming, steam, reviews, news, tutorials" />
   
  <meta name="robots" content="index, follow">
  <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

  <link rel="shortcut icon" href="http://www.thelinuxrain.com:80/assets/images/favicon.gif" type="image/gif" />
  <link rel="icon" href="http://www.thelinuxrain.com:80/assets/images/favicon.gif" type="image/gif" />
  <link rel="shortlink" type="text/html" href="http://www.thelinuxrain.com:80/x/1bpl1o2">


  <!--[if lt IE 9]>
	<script src="http://www.thelinuxrain.com:80/assets/dist/html5shiv.js"></script>  <![endif]-->

  <meta property="og:site_name" content="The Linux Rain" />
  <meta property="og:type" content="article" />
  <meta property="og:title" content="The buttons of YAD | The Linux Rain" />
  <meta property="og:description" content="I use the YAD dialog program quite a lot in my shell scripts. Written and maintained by Victor Ananjevksy, YAD is easy to use and has dozens of handy options." />
  <meta property="og:url" content="http://www.thelinuxrain.com:80/articles/the-buttons-of-yad" />
  <meta property="og:image" content="http://www.thelinuxrain.com:80/thumbs/headimage-7006305dc56a332e9a148feae497391f.jpg" />

    <meta property="article:section" content="Tutorials" />
  
      <meta property="article:tag" content="yad" />
    <meta property="article:tag" content="dialog" />
    <meta property="article:tag" content="cli" />
    <meta property="article:tag" content="tutorials" />
    <meta property="article:tag" content="gtk" />
    <meta property="article:tag" content="scripts" />
    <meta property="article:tag" content="gui" />
    
    <meta property="article:published_time" content="2017-04-02T18:00:00+00:00" />
  
</head>

<body id="page" class=" article">
   <script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', 'UA-46481365-1', 'thelinuxrain.com');
	  ga('send', 'pageview');

  </script>
<header id="main-header">
	<a href="http://www.thelinuxrain.com:80"><h1 class="text-center">
	The Linux Rain	<small class="clearfix">Linux General/Gaming News, Reviews and Tutorials</small>
	</h1>
	</a>
</header>
 <nav id="navbar-main" class="navbar navbar-inverse" role="navigation">
	<div class="container-fluid">
		 <div class="navbar-header">
		      <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1">
			<span class="sr-only">Toggle navigation</span>
			<span class="icon-bar"></span>
			<span class="icon-bar"></span>
			<span class="icon-bar"></span>
		      </button>
		</div>
			<div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
			<ul class="nav navbar-nav">        <li><a class="is-active" href="http://www.thelinuxrain.com:80">Home</a></li>
        <li><a href="http://www.thelinuxrain.com:80/about">About</a></li>
        <li><a href="http://www.thelinuxrain.com:80/contact">Contact</a></li>
        <li><a href="http://www.thelinuxrain.com:80/submit-an-article">Submit Tip/Article</a></li>
    <li class="dropdown-eligible"><a href="#categories">Categories</a><ul class="sub-menu">
		
			<li><a href="http://www.thelinuxrain.com:80/category:Reviews">Reviews</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:News">News</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Tutorials">Tutorials</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Editorials">Editorials</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Announcements">Announcements</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Previews">Previews</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Upcoming">Upcoming</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Advocacy">Advocacy</a></li>
			<li><a href="http://www.thelinuxrain.com:80/category:Overviews">Overviews</a></li>
	</ul>
</li></ul>
		</div> <!-- /.navbar-collapse -->
	</div> <!-- /.container-fluid -->
</nav>
<div class="container-fluid">
<div class="main">
<div class="article-content">
				<header>
					<img class="img-responsive center-block" src="http://www.thelinuxrain.com:80/content/01-articles/150-the-buttons-of-yad/headimage.jpg">
					<h1 class="text-center">The buttons of YAD</h1>
					<h4 class="text-center">By <span class="text-uppercase">Bob Mesibov</span>, published 02/04/2017 in <a href="http://www.thelinuxrain.com:80/category:Tutorials">Tutorials</a></h4>
				</header>
					<hr>
				<div class="article-inner-content">
					<p>I use the <a href="https://sourceforge.net/projects/yad-dialog/">YAD</a> dialog program quite a lot in my shell scripts. Written and maintained by Victor Ananjevksy, YAD is easy to use and has dozens of handy options.</p>
<p>In previous <em>Linux Rain </em> articles demonstrating YAD (<a href="http://www.thelinuxrain.com/articles/multiple-item-data-entry-with-yad">here</a>, <a href="http://www.thelinuxrain.com/articles/scripting-a-fancy-chooser-for-recently-used-files">here</a> and <a href="http://www.thelinuxrain.com/articles/tips-on-getting-and-editing-suggesting-user-input">here</a>), I used only the default YAD buttons, "Cancel" and "OK". Those are the two buttons you get if you don't include any button options in your YAD command, as here:</p>
<pre><code>yad --text "Would you like to participate in a survey?"</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/150-the-buttons-of-yad/1.png" alt="1" /></figure>
<p>A more sensible choice of buttons for this particular dialog would be "Yes" and "No". You can get those buttons by specifying each with a "--button" option:</p>
<pre><code>yad --text "Would you like to participate in a survey?" \
--button=gtk-no:1 --button=gtk-yes:0</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/150-the-buttons-of-yad/2.png" alt="2" /></figure>
<h1>Button order and position</h1>
<p>Want "Yes" to the left of "No"? The order of the buttons is determined by their order in the command:</p>
<pre><code>yad --text "Would you like to participate in a survey?" \
--button=gtk-yes:0 --button=gtk-no:1</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/150-the-buttons-of-yad/3.png" alt="3" /></figure>
<p>You can also move the buttons around at the bottom of the dialog box. The choices for the "--buttons-layout" option are <em>center</em>, <em>edge</em>, <em>end</em>, <em>spread</em> and <em>start</em>, with <em>end</em> being the default. Here's <em>center</em>:</p>
<pre><code>yad --text "Would you like to participate in a survey?" \
--button=gtk-no:1 --button=gtk-yes:0 --buttons-layout=center</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/150-the-buttons-of-yad/4.png" alt="4" /></figure>
<p>You can even have no buttons at all. This might be OK for a notification dialog, but you'd need to click on the window-closing "X" to close the dialog:</p>
<pre><code>yad --text "Would you like to participate in a survey?" --no-buttons</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/150-the-buttons-of-yad/5.png" alt="5" /></figure>
<h1>Button text and icons</h1>
<p>The "gtk-yes" and "gtk-no" instructions determine how the buttons are labelled. Those instructions refer YAD to the many stock GTK images, which on my system live in <em>/usr/share/icons</em> subdirectories. Here are more stock examples:</p>
<pre><code>yad --button=gtk-print:1 --button=gtk-quit:1  --button=gtk-dialog-error:1</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/150-the-buttons-of-yad/6.png" alt="6" /></figure>
<p>You can also write your own button text:</p>
<pre><code>yad --text "Would you like to participate in a survey?" \
--button=gtk-no:1 --button="I'll think about it":1 --button=gtk-yes:0</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/150-the-buttons-of-yad/7.png" alt="7" /></figure>
<p>To put your own icons on a button, precede the path to the icon with a "!", like this:</p>
<pre><code>yad --button=" One!$HOME/.icons/s1.png":1 \
--button=" Two!$HOME/.icons/s2.png":1 \
--button=" Three!$HOME/.icons/s3.png":1</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/150-the-buttons-of-yad/8.png" alt="8" /></figure>
<p>Note that this won't work as a command in a BASH terminal, because BASH will interpret the "!" as a history operator. To get it to work in a terminal, temporarily disable BASH history with <strong>set +H</strong>. Restore history with <strong>set -H</strong>.</p>
<p>You can also label a button with a shell variable:</p>
<pre><code>foo=$(date +"%d %b %Y")
yad --text="Click on the date:" --button=gtk-cancel:1 --button="$foo":0</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/150-the-buttons-of-yad/9.png" alt="9" /></figure>
<h1>Multiple button outputs</h1>
<p>Probably the most frequent use of YAD is in allowing the user to make a choice (a date, a file, a colour, a text string etc) and sending that choice to standard output. Whether that happens or not depends on the exit status of the YAD command.</p>
<p>If the user clicks the "Cancel" button, or any button assigned an exit status of 1 (as in "--button=gtk-no:<strong>1</strong>"), then YAD exits without sending anything to stdout. YAD also exits this way if the user presses "Esc" on the keyboard or closes YAD by clicking on the window's "X", although in this case the exit status is 252.</p>
<p>If the user clicks the "OK" button, or any button assigned an exit status of 0 (as in "--button=gtk-yes:<strong>0</strong>"), then YAD sends the choice to stdout. YAD also does this if the user presses "Enter" on the keyboard.</p>
<p>Other exit status values can be assigned to buttons, to allow other actions in a shell script. For example, suppose you have the three browsers Chromium, Firefox and Dillo on your system. The following script will allow you to launch the selected browser (or to open a new window in an existing session if that browser is already running). Pressing "Enter" will cause YAD to exit in this case.</p>
<pre><code>#!/bin/bash

yad --text="Choose a browser to launch:" \
--button=gtk-cancel:1 \
--button="Chromium":2 \
--button="Firefox":3 \
--button="Dillo":4

foo=$?

[[ $foo -eq 1 ]] &amp;&amp; exit 0

if [[ $foo -eq 2 ]]; then
chromium &amp;&amp; exit 0

elif [[ $foo -eq 3 ]]; then
firefox &amp;&amp; exit 0

else
dillo &amp;&amp; exit 0
fi</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/150-the-buttons-of-yad/10.png" alt="10" /></figure>
<h1>Buttons and commands</h1>
<p>It's possible to put a command in the button option instead of an exit status, like this:</p>
<pre><code>yad --text="Choose a browser to launch:" \
--button=gtk-cancel:1 \
--button="Chromium":chromium \
--button="Firefox":firefox \
--button="Dillo":dillo</code></pre>
<p>YAD's "form" dialog allows you to do this in another way, by stacking buttons one on top of the other. The trick is to use the "FBTN" (or "fbtn") field type:</p>
<pre><code>yad --form --width=250 --text="Choose a browser to launch:" \
--field="Chromium":fbtn "chromium" \
--field="Firefox":fbtn "firefox" \
--field="Dillo":fbtn "dillo" \
--button=gtk-cancel:1</code></pre>
<figure><img src="http://www.thelinuxrain.com:80/content/01-articles/150-the-buttons-of-yad/11.png" alt="11" /></figure>
<p><strong>NOTE</strong> that in both these cases the YAD dialog <em>doesn't exit</em> after the browser-launching command is executed. The dialog window remains open until YAD is closed manually. For this reason the "buttons-with-exit-status-in-a-script" strategy is better if you're using buttons alone for making a choice.</p>
<h1>...and lots more</h1>
<p>The YAD man page is very good, but for more ideas on using YAD see <a href="http://smokey01.com/yad/">this page</a> from Puppy Linux enthusiast "smokey01".</p>
<p><em>Top image by OhWeh in <a href="https://commons.wikimedia.org/wiki/File:Kn%C3%B6pfe_2010-01-18-001.jpg">Wikimedia Commons</a></em></p>					<div class="about-author"><hr />
<h4>About the Author</h4>
<p>Bob Mesibov is Tasmanian, retired and a keen Linux tinkerer.</p></div>										<span class="tags">Tags:
											<a href="/tag:yad">yad</a>
											<a href="/tag:dialog">dialog</a>
											<a href="/tag:cli">cli</a>
											<a href="/tag:tutorials">tutorials</a>
											<a href="/tag:gtk">gtk</a>
											<a href="/tag:scripts">scripts</a>
											<a href="/tag:gui">gui</a>
									</span>
				</div> <!-- /.article-inner-content -->
			<div id="disqus_container">
								<div id="disqus_thread"></div>
<script type="text/javascript">
  var disqus_shortname  = 'thelinuxrain'; // required: replace example with your forum shortname
  var disqus_title      = "The buttons of YAD";
  var disqus_developer  = 'false'; // developer mode
  var disqus_identifier = 'articles/the-buttons-of-yad';
  var disqus_url        = 'http://www.thelinuxrain.com:80/articles/the-buttons-of-yad';

  (function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
    dsq.src = 'http://' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
  })();
</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<a href="http://disqus.com" class="dsq-brlink">blog comments powered by <span class="logo-disqus">Disqus</span></a>
			</div>
			</article>
</div> <!-- /.article-content -->
<aside class="right-sidebar">
	<section>
		<form role="search" action="http://www.google.com" id="cse-search-box">
	 <div class="google-search-box">
		<div class="input-group">
			<input type="hidden" name="cx" value="partner-pub-5941131116498030:3231598707" />
			<input type="hidden" name="ie" value="UTF-8" />
			<input class="form-control search-field" type="text" name="q" />
			<span class="input-group-btn">
				<input class="btn search-submit" type="submit" name="sa" value="" />
			</span>
		</div>
	</div>
</form>
<script type="text/javascript" src="http://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
	</section>
	
	<section>
		<h4>Follow Us</h4>
		<div class="social-follow-buttons">
		<a href="https://facebook.com/thelinuxrain" target="_blank"><span class="social-button btn-facebook"></span></a>
		<a href="https://twitter.com/intent/user?screen_name=TheLinuxRain" target="_blank"><span class="social-button btn-twitter"></span></a>
		<a href="http://plus.google.com/105314050105739144609?prsrc=3" target="_blank"><span class="social-button btn-google"></span></a>
		<a href="feed" target="_blank"><span class="social-button btn-rss"></span></a>
		</div>

	</section>
	<section>
		<h4>Recent Articles</h4>
		<div class="widget_recent_entries">
			<ul class="sidebar-links">
			
			<li>
				<a href="http://www.thelinuxrain.com:80/articles/the-buttons-of-yad">The buttons of YAD</a>
			</li>
			
			
			<li>
				<a href="http://www.thelinuxrain.com:80/articles/a-look-at-gnome-recipes">A Look at GNOME Recipes</a>
			</li>
			
			
			<li>
				<a href="http://www.thelinuxrain.com:80/articles/grep-vs-awk-vs-ruby-and-a-uniq-disappointment">grep vs AWK vs Ruby, and a uniq disappointment</a>
			</li>
			
			
			<li>
				<a href="http://www.thelinuxrain.com:80/articles/netflix-flicks-the-on-switch-for-firefox-on-linux">Netflix flicks the 'On' Switch for Firefox on Linux</a>
			</li>
			
			
			<li>
				<a href="http://www.thelinuxrain.com:80/articles/gnome-3-24-released">GNOME 3.24 'Portland' Released</a>
			</li>
			
</ul>
			</div>
	</section>
	<section>
		<h4>Editor Picks</h4>
		<div class="widget_recent_entries">
			
<ul class="sidebar-links">

	<li> <a href="http://www.thelinuxrain.com:80/articles/hitman-the-complete-first-season-linux-game-review">Review: HITMAN - The Complete First Season</a></li>
	<li> <a href="http://www.thelinuxrain.com:80/articles/scripting-an-arithmeticker">Scripting an arithmeticker</a></li>

</ul>
		</div>
	</section>
	<section>
		<h4>Linux Links</h4>
		<div class="widget_recent_entries">
			
<ul class="sidebar-links">

	<li> <a href="http://www.tuxarena.com/">TuxArena</a></li>

</ul>
		</div>
	</section>
	<section>
	<a href="https://www.resetthenet.org" target="_blank"><img class="img-responsive" src="http://www.thelinuxrain.com:80/assets/images/take-back-reset-the-net.png"></a>
	</section>
	<section>
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- SidebarAd -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5941131116498030"
     data-ad-slot="4271339906"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
	</section>
	<section>
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- SkyscraperAd -->
<ins class="adsbygoogle"
style="display:block;width:160px;height:600px;margin:0 auto;"
data-ad-client="ca-pub-5941131116498030"
data-ad-slot="7588929504"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
	</section>
</aside>
</div> <!-- /.main -->
</div> <!-- /.container-fluid -->
<div id="bottom-ad">
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<!-- BottomAdResponsive -->
	<ins class="adsbygoogle"
		 style="display:block"
		 data-ad-client="ca-pub-5941131116498030"
		 data-ad-slot="3688184305"
		 data-ad-format="auto"></ins>
	<script>
	(adsbygoogle = window.adsbygoogle || []).push({});
	</script>
</div>
  <footer>
    	<div class="text-center"><p>© 2013-2016 The Linux Rain <br />
Powered by the <a href="http://getkirby.com">KirbyCMS</a><br />
Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.</p></div>
  </footer>
  <link rel="stylesheet" href="http://www.thelinuxrain.com:80/css/bootstrap.min.css?v=2" />  <link rel="stylesheet" href="http://www.thelinuxrain.com:80/css/style.css?v=20" />  <script src="http://www.thelinuxrain.com:80/js/jquery.min.js"></script>  <script src="http://www.thelinuxrain.com:80/js/bootstrap.min.js"></script>	<script>

	jQuery(document).ready(function($) {

		$('.dropdown-eligible').children('a').append(' <span class="caret"></span>');
		$('.dropdown-eligible').children('a').addClass('dropdown');
		$('.dropdown-eligible').children('a').attr('data-toggle', 'dropdown');
		$('.nav .sub-menu').addClass('dropdown-menu');
	});

	</script>
</body>
</html>
